If you wish to help support this site please disable your adblock program.


Click here to become a Premium Member : No ads site-wide : Forum privileges : Upgraded services : Giveaway & moreSupport the Site! Support Us!
Tukui » ElvUI » Technical Support » Blocking Chinese
  1. Challenger glove2004
    offline
    Member

    XP: 
     

    9 / 1337

    Hello,

    Just wondering how I can enable it to show Chinese in trade chat. Wasn't able to find it.

    Thanks in advance..

    glove.

    Posted 1 year ago - #1
     


  2. If you wish to help support this site please disable your adblock program.


    Duelist sortokk
    offline
    Blizzard

    XP: 
     

    585 / 1337

    It is not blocking Chinese specifically, more so the font does not support it. Choose a font that does support Chinese characters.

    Yep, it's awesome. No, I can't tell you. :)
    Posted 1 year ago - #2
     
  3. Hero Pat
    offline
    VIP

    XP: 
     

    1337 / 1337

    sortokk said:
    It is not blocking Chinese specifically, more so the font does not support it. Choose a font that does support Chinese characters.

    default for chat in ElvUI is PT Sans Narrow no? It should support unicode even inside WoW.

    Hydra has it set for the media player for the Tukui rainmeter skin.

    Posted 1 year ago - #3
     
  4. offline
    Moderator

    XP: 
     

    1337 / 1337

    sortokk said:
    It is not blocking Chinese specifically, more so the font does not support it. Choose a font that does support Chinese characters.

    It actually blocks chinese in channels, yell and say if you're using enUS or enGB client.

    ElvUI\modules\chat\spam.lua

    local blockMessages = {
    	['[\227-\237]'] = true, --Credit: Ketho (EU-Boulderfist)
    }
    
    function CH:SpamFilter(event, msg)
    	for blockMessage in pairs(blockMessages) do
    		if strfind(msg, blockMessage) then
    			return true
    		end
    	end
    end

    ElvUI\modules\chat\chat.lua

    local locale = GetLocale()
    function CH:CHAT_MSG_CHANNEL(event, message, author, ...)
    
    	local isSpam = nil
    	if locale == 'enUS' or locale == 'enGB' then
    		isSpam = CH.SpamFilter(self, event, message, author, ...)
    	end
    
    	if isSpam then
    		return true;
    	else
    		local blockFlag = false
    [...]
    function CH:CHAT_MSG_YELL(event, message, author, ...)
    	local isSpam = nil
    	if locale == 'enUS' or locale == 'enGB' then
    		isSpam = CH.SpamFilter(self, event, message, author, ...)
    	end
    
    	if isSpam then
    		return true;
    	else
    		local blockFlag = false
    [...]
    function CH:CHAT_MSG_SAY(event, message, author, ...)
    	local isSpam = nil
    	if locale == 'enUS' or locale == 'enGB' then
    		isSpam = CH.SpamFilter(self, event, message, author, ...)
    	end
    
    	if isSpam then
    		return true;
    	else
    		return CH.FindURL(self, event, message, author, ...)
    	end
    end

    The reason for filtering it was that the chinese characters would grow outside the boundaries of the chat frame. Since most people who care about seeing chinese in WoW use the chinese client, the best solution was to filter it.

    Posted 1 year ago - #4
     
  5. Duelist sortokk
    offline
    Blizzard

    XP: 
     

    585 / 1337

    My mistake then, thank you for correcting me for Blazeflack.

    Yep, it's awesome. No, I can't tell you. :)
    Posted 1 year ago - #5
     
  6. Challenger glove2004
    offline
    Member

    XP: 
     

    9 / 1337

    So is there anything I can do?? or just sol

    Posted 1 year ago - #6
     
  7. offline
    Moderator

    XP: 
     

    1337 / 1337

    glove2004 said:
    So is there anything I can do?? or just sol

    You can remove

    	if locale == 'enUS' or locale == 'enGB' then
    		isSpam = CH.SpamFilter(self, event, message, author, ...)
    	end

    from the 3 blocks of code linked in my earlier post.

    Posted 1 year ago - #7
     
  8. Challenger glove2004
    offline
    Member

    XP: 
     

    9 / 1337

    Thank you blaze.

    Worked perfect thanks a bunch

    Posted 1 year ago - #8
     
  9. offline
    Member

    XP: 
     

    1 / 1337

    Was wondering why its not displaying Chinese on my english client while ElvUI works perfectly in my TW client.

    Could this be added in as a chat option perhaps instead of having to hack the codes everytime there's an update?

    TIA

    Posted 1 year ago - #9
     
  10. Gladiator Repooc
    offline
    Moderator

    XP: 
     

    1005 / 1337

    wingiee said:
    Was wondering why its not displaying Chinese on my english client while ElvUI works perfectly in my TW client.

    Could this be added in as a chat option perhaps instead of having to hack the codes everytime there's an update?

    TIA

    IF you look at the code, basically its saying if its an ebglish client block chinese... the tw client is not an english client so it works fine for u

    Posted 1 year ago - #10
     
  11. Challenger calgarymarc
    offline
    Member

    XP: 
     

    14 / 1337

    As of the update yesterday (6.89) - Japanese/Chinese characters are once again displaying in Trade Chat. Is there anything I can do to remove it?
    My apologies if this isn't the right place for this question.

    Posted 9 months ago - #11
     
  12. offline
    Moderator

    XP: 
     

    1337 / 1337

    calgarymarc said:
    As of the update yesterday (6.89) - Japanese/Chinese characters are once again displaying in Trade Chat. Is there anything I can do to remove it?
    My apologies if this isn't the right place for this question.

    Elv removed the code which does the blocking.

    You can download BlockChinese and see if it works along side ElvUI (it should).
    It only blocks chinese, if you want to block japanese and korean too, then open BlockChinese.lua and do the following edit:
    Find

    if strfind(msg, "[\228-\233]") then

    Replace with

    if strfind(msg, "[\227-\237]") then
    Posted 9 months ago - #12
     
RSS feed for this topic

Reply

You must log in to post.