Loading...

PROJECTAZILROKA LUA Error

#1
Version of ElvUI: 11.51

Version of S&L: 3.78

Were you able to reproduce the issue with only "ElvUI", "ElvUI_Config" and "Shadow & Light" being enabled?: Yes

Did you disable all addons to make sure the issue comes from ElvUI or S&L?: Yes

Did you check for lua errors?: LUA error is actually what appears, two of them

If you received an error then post it below (use the 'code' bbcode):

Code: Select all

Message: ...\AddOns\ProjectAzilroka\Modules\ReputationReward.lua:155: attempt to index local 'rewardsFrame' (a nil value)
Time: Wed Sep  2 15:51:21 2020
Count: 2
Stack: ...\AddOns\ProjectAzilroka\Modules\ReputationReward.lua:155: attempt to index local 'rewardsFrame' (a nil value)
[string "=[C]"]: ?
[string "@Interface\AddOns\ProjectAzilroka\Modules\ReputationReward.lua"]:155: in function <...\AddOns\ProjectAzilroka\Modules\ReputationReward.lua:103>
[string "=(tail call)"]: ?
[string "=[C]"]: in function `QuestInfo_Display'
[string "@Interface\FrameXML\QuestFrame.lua"]:127: in function <Interface\FrameXML\QuestFrame.lua:121>
[string "=[C]"]: in function `Show'
[string "@Interface\FrameXML\UIParent.lua"]:2740: in function `SetUIPanel'
[string "@Interface\FrameXML\UIParent.lua"]:2585: in function `ShowUIPanel'
[string "@Interface\FrameXML\UIParent.lua"]:2453: in function <Interface\FrameXML\UIParent.lua:2449>
[string "=[C]"]: in function `SetAttribute'
[string "@Interface\FrameXML\UIParent.lua"]:3307: in function `ShowUIPanel'
[string "@Interface\FrameXML\QuestFrame.lua"]:99: in function <Interface\FrameXML\QuestFrame.lua:22>

Locals: 

Code: Select all

Message: ...\AddOns\ProjectAzilroka\Modules\ReputationReward.lua:155: attempt to index local 'rewardsFrame' (a nil value)
Time: Wed Sep  2 15:54:30 2020
Count: 2
Stack: ...\AddOns\ProjectAzilroka\Modules\ReputationReward.lua:155: attempt to index local 'rewardsFrame' (a nil value)
[string "=[C]"]: ?
[string "@Interface\AddOns\ProjectAzilroka\Modules\ReputationReward.lua"]:155: in function <...\AddOns\ProjectAzilroka\Modules\ReputationReward.lua:103>
[string "=(tail call)"]: ?
[string "=[C]"]: in function `QuestInfo_Display'
[string "@Interface\FrameXML\QuestFrame.lua"]:519: in function <Interface\FrameXML\QuestFrame.lua:506>
[string "=[C]"]: in function `Show'
[string "@Interface\FrameXML\QuestFrame.lua"]:62: in function <Interface\FrameXML\QuestFrame.lua:22>

Locals: 
Please explain the issue you're having with as much detail as possible. If there is a way to reproduce the issue then mention that too in as much detail as possible.:
There's isn't an Apparent issue that I can tell. After completing a quest and accepting the rewards, etc, the two LUA errors appear.

Do you have any other information which might help us track down the issue?:
These errors are specifically happening in Suramar for the quests right before The Gondolier (I don't remember the name of the quest), but it's part of the story progress.

If your issue is graphical then please take some screenshots to illustrate it. You can attach them to your post:
Not graphical that I'm aware of. Just reporting an error I received to hopefully help anyone else that may experience it, whatever it may do.

Who is online

Users browsing this forum: No registered users and 2 guests