Loading...
Forum Rules:
Before creating a thread here then please read [FOR TECH SUPPORT] README FIRST.

When you create a new thread then please make sure you use the "Tukui Tech Support" post template. See the link above for more information.

Tukui not loading after patch.

#12
Please include a screenshot after typing "/tukui status" and ANY lua errors you had displayed if you run into problem. Just telling us it is not working won't help.

What I recommend.

1- In your addons list, just check Tukui and Tukui_Config. Disable everything else.
2- If still having issue, backup your WTF folder (optionnal) and do a reset to default with "/tukui reset" command.
Don't commit on master when drunk.

Tukui not loading after patch.

#13
Volitar wrote:
Wed Dec 12, 2018 10:13 pm
I'm having it work fine for some characters and completely busted with others. Both using global settings.
Which class are not working?
Don't commit on master when drunk.

Tukui not loading after patch.

#14
I'm seeing the same thing concerning the chat windows. Information is below. I'm also receiving 3 LUA Errors. All Addons minus Tukui are disabled.

https://imgur.com/a/63SZZJv

Error 1:

Message: ...\AddOns\Tukui\Modules\DataTexts\Elements\Friends.lua:112: Usage: BNGetGameAccountInfo(ID)
Time: Wed Dec 12 17:22:14 2018
Count: 1
Stack: ...\AddOns\Tukui\Modules\DataTexts\Elements\Friends.lua:112: Usage: BNGetGameAccountInfo(ID)
[C]: ?
...\AddOns\Tukui\Modules\DataTexts\Elements\Friends.lua:112: in function <...\AddOns\Tukui\Modules\DataTexts\Elements\Friends.lua:106>
...\AddOns\Tukui\Modules\DataTexts\Elements\Friends.lua:368: in function `Update'
...\AddOns\Tukui\Modules\DataTexts\Elements\Friends.lua:400: in function <...\AddOns\Tukui\Modules\DataTexts\Elements\Friends.lua:374>
[C]: in function `Enable'
Interface\AddOns\Tukui\Modules\DataTexts\Core.lua:264: in function `Load'
Interface\AddOns\Tukui\Modules\DataTexts\Core.lua:280: in function `Enable'
Interface\AddOns\Tukui\Core\Loading.lua:153: in function <Interface\AddOns\Tukui\Core\Loading.lua:42>

Locals: (*temporary) = nil


Error 2:
Message: ...\AddOns\Tukui\Modules\DataTexts\Elements\Friends.lua:112: Usage: BNGetGameAccountInfo(ID)
Time: Wed Dec 12 17:30:06 2018
Count: 30
Stack: ...\AddOns\Tukui\Modules\DataTexts\Elements\Friends.lua:112: Usage: BNGetGameAccountInfo(ID)
[C]: ?
...\AddOns\Tukui\Modules\DataTexts\Elements\Friends.lua:112: in function <...\AddOns\Tukui\Modules\DataTexts\Elements\Friends.lua:106>
...\AddOns\Tukui\Modules\DataTexts\Elements\Friends.lua:368: in function <...\AddOns\Tukui\Modules\DataTexts\Elements\Friends.lua:355>

Locals: (*temporary) = nil

Error 3:
Message: ...\AddOns\Tukui\Modules\DataTexts\Elements\Friends.lua:112: Usage: BNGetGameAccountInfo(ID)
Time: Wed Dec 12 17:22:31 2018
Count: 1
Stack: ...\AddOns\Tukui\Modules\DataTexts\Elements\Friends.lua:112: Usage: BNGetGameAccountInfo(ID)
[C]: ?
...\AddOns\Tukui\Modules\DataTexts\Elements\Friends.lua:112: in function <...\AddOns\Tukui\Modules\DataTexts\Elements\Friends.lua:106>
...\AddOns\Tukui\Modules\DataTexts\Elements\Friends.lua:368: in function `Update'
...\AddOns\Tukui\Modules\DataTexts\Elements\Friends.lua:400: in function <...\AddOns\Tukui\Modules\DataTexts\Elements\Friends.lua:374>
[C]: in function `Enable'
Interface\AddOns\Tukui\Modules\DataTexts\Core.lua:233: in function `Reset'
Interface\AddOns\Tukui\Core\Install.lua:11: in function <Interface\AddOns\Tukui\Core\Install.lua:9>

Locals: (*temporary) = nil

Tukui not loading after patch.

#15
Reinstalled after the last hotfix from the downloaded ZIP. Backed up and did a completely fresh install. Default/global settings.
Screenshots
Show

Installing fresh, just before "Complete" UI reload:
Image
After that reload:
Image
"/tukui status"
Image
LUA error
Show
Message: ...\AddOns\Tukui\Modules\DataTexts\Elements\Friends.lua:112: Usage: BNGetGameAccountInfo(ID)
Time: Wed Dec 12 17:24:26 2018
Count: 1
Stack: ...\AddOns\Tukui\Modules\DataTexts\Elements\Friends.lua:112: Usage: BNGetGameAccountInfo(ID)
[C]: ?
...\AddOns\Tukui\Modules\DataTexts\Elements\Friends.lua:112: in function <...\AddOns\Tukui\Modules\DataTexts\Elements\Friends.lua:106>
...\AddOns\Tukui\Modules\DataTexts\Elements\Friends.lua:368: in function `Update'
...\AddOns\Tukui\Modules\DataTexts\Elements\Friends.lua:400: in function <...\AddOns\Tukui\Modules\DataTexts\Elements\Friends.lua:374>
[C]: in function `Enable'
Interface\AddOns\Tukui\Modules\DataTexts\Core.lua:264: in function `Load'
Interface\AddOns\Tukui\Modules\DataTexts\Core.lua:280: in function `Enable'
Interface\AddOns\Tukui\Core\Loading.lua:153: in function <Interface\AddOns\Tukui\Core\Loading.lua:42>

Locals: (*temporary) = nil

Tukui not loading after patch.

#16
Tukz wrote:
Wed Dec 12, 2018 10:21 pm
Volitar wrote:
Wed Dec 12, 2018 10:13 pm
I'm having it work fine for some characters and completely busted with others. Both using global settings.
Which class are not working?
Warrior and DH were fine but Druid wasn't working.

Tukui not loading after patch.

#18
18.20 - no changes.

LUA ERROR:

Message: Interface\FrameXML\ActionButton.lua:471: assertion failed!
Time: Thu Dec 13 15:28:29 2018
Count: 1
Stack: Interface\FrameXML\ActionButton.lua:471: assertion failed!
[C]: in function `assert'
Interface\FrameXML\ActionButton.lua:471: in function `ActionButton_ShowGrid'
Interface\AddOns\Tukui\Modules\ActionBars\Core.lua:78: in function `ShowGrid'
Interface\AddOns\Tukui\Modules\ActionBars\Core.lua:396: in function `Enable'
Interface\AddOns\Tukui\Core\Loading.lua:94: in function <Interface\AddOns\Tukui\Core\Loading.lua:42>

Locals: (*temporary) = nil

Tukui not loading after patch.

#19
Okaryna wrote:
Thu Dec 13, 2018 2:29 pm
18.20 - no changes.

LUA ERROR:

Message: Interface\FrameXML\ActionButton.lua:471: assertion failed!
Time: Thu Dec 13 15:28:29 2018
Count: 1
Stack: Interface\FrameXML\ActionButton.lua:471: assertion failed!
[C]: in function `assert'
Interface\FrameXML\ActionButton.lua:471: in function `ActionButton_ShowGrid'
Interface\AddOns\Tukui\Modules\ActionBars\Core.lua:78: in function `ShowGrid'
Interface\AddOns\Tukui\Modules\ActionBars\Core.lua:396: in function `Enable'
Interface\AddOns\Tukui\Core\Loading.lua:94: in function <Interface\AddOns\Tukui\Core\Loading.lua:42>

Locals: (*temporary) = nil
You didn't update, that was an error from using Tukui for 8.0.1 (18.18 version and less)

Line 78 on 18.20 is not a ShowGrid function as displayed in your error. It's a button state. First 'ShowGrid' function should be displayed starting at 80 in 18.20.

https://git.tukui.org/Tukz/Tukui/blob/m ... re.lua#L78

Please update correctly.

Thank you.
Don't commit on master when drunk.

Who is online

Users browsing this forum: s_geisser and 3 guests