Loading...
Before reporting a bug, try to do a clean re-install:
  1. Remove all entries of Tukui Client from Add/Remove Programs.
  2. Remove data folder for Tukui Client:
    • Open a Windows Explorer window (folder).
    • Type the following in the address bar and press Enter:

      Code: Select all

      %localappdata%
    • Find the Tukui folder and delete it.
  3. Download the latest version of the Tukui Client and install it.

Tukui Client for Classic no longer shows ElvUi

#1
Hi, Essentially as of this afternoon my ElvUi seems to have stopped working in-game. Since I had recent shut my computer down I figured something went wrong.
Followed advice to reinstall Tukui Client. Using latest version 3.2.7.0

On startup after reinstall, I select the World of Warcraft folder as directed by the client app.
Note that the post in this forum suggests something that simply does not work as stated. If we 'File' > 'Set Directory' to World of Warcraft\_retail_\
the client responds stating that World of Warcraft Launcher.exe not found or Data folder not detected in that directory (true - neither exist in the retail directory)
Note that my Retail elvui is working as it always was.

When I switch to classic the addon list is blank. This I find odd as "i did nothing" other than shut down computer. Clearly I did something during the shutdown that a reinstall has not repaired.
Selecting the directory for classic has the same issue as retail - the only way it works is to select the World of Warcraft folder which I suspect is wrong. Selecting the _classic_ subfolder gets an error as there is no Data directory there. Creating a Data directory to make the Set Directory happy "works" but results in still no addons listed and also the Install button is in fact an Update button.

So I'm not sure what to try to get the client update tool to work. I was only really in there to try investigate/repair my installation since it was not working in game however I have to post that in the ElvUI forum after I've finished troubleshooting that.

I've seen another post about the same thing which was answered and no update from the OP so assume it fixed it for them.

Any suggestions welcome.

Tukui Client for Classic no longer shows ElvUi

#2
Go to the wow folder and press ok.

Don’t go to the retail or classic or addons. Just go to wow and press ok.

It’s ok if the client doesn’t show any addons.

Just download the ones you need. (even if you have them installed)
I always recommend backing up your WTF folder - where your profiles/settings for all addons, including ElvUI are stored.

Tukui Client for Classic no longer shows ElvUi

#3
Yes this is what I did and yes it works for Retail but not for Classic for some reason.
I eluded to the ElvUi addon issue I had. Usually I let the TukUI client handle updates for me but since I had this issue I ended up manually deleting the addon and manually installing it.
The addon works in classic again just as it did this morning.
I am now recalling with more rigour all of the actions I took that I may have previously not noted in case it helps someone. I ireckon something I did caused this.

I don't normally shutdown computer - only Restart and Sleep. Today I shut down because of notification of a power outage in the area for line work.

After I started PC I wanted to start TukUi client so _ used windows +R to start it and inexplicably typed elvui. I forgot about this earlier. This utility is not even anything to do with Tukui - I think it was someone else's attempt to perform the same useful function (of updating ElvUi) that TukUi client now handles so well.

So the "Elvui Updater" appeared progress window and I thought Oh it must be a Tukui client update. Clicked Update. It finished and stayed on the screen. After about 30 seconds I closed it and just started wow.
I noticed the client was not running so that is when I started troubleshooting.
I suspect my issue might have been caused by manually running that updater since that's the only odd thing I did. I do trust the source of the updater utility but as I said it was a mistake to run it.

When I manually installed Elvui addon just now I also deleted the third party "Updater" directory from %localappdata% - so I changed two things and now addon works. I rather suspect manually reinstall of addon was the thing to fix it and this other updater broke it although I do wonder how it knew to look in _classic_. I will ask the author of that tool about it.

Meanwhile back on the Tukui client I see no addon listed and the button is Update not Install so I might still have a setting (registry?) that is convincing the Tukui Client that I have something installed yet for some reason it does not show in the list.

Tukui Client for Classic no longer shows ElvUi

#5
Not sure I'm being clear. Normally in the Client I can see ElvUI listed with it's version etc. It's not there and I can't see how to bring it back. Had reinstalled client as described at top of this forum but nothing I do will make it visible as such. I manually installed ElvUi because the Install button on the client was not present. It was instead an Update button that normally I only see if the client recognises that I have something installed (ElvUi). Normally for me it's only showing ElvUi in the list.

Who is online

Users browsing this forum: GreyWolf1972 and 2 guests