Loading...

ElvUI ExtraActionBars

#1
Hello All,

Been having some strange issues with ElvUI ExtraActionBars as of today. See screenshot below, especially the red highlighted sections. Essentially, I'm getting a non skinned clone of one of my extra action bars (#8 to be precise). It acts as a clone in every manner - when I add a spell, it adds them to both. I'm also getting a LUA error on login, and every time I try to change the settings of bar #8 (even enabling/disabling the bar).

Code: Select all

1x ...rfaceElvUI\Modules\actionbars\ActionBars.lua:249: attempt to index field 'mover' (a nil value)
...rfaceElvUI\Modules\actionbars\ActionBars.lua:249: in function `PositionAndSizeBar'
...rfaceElvUI\Modules\actionbars\ActionBars.lua:246: in function `PositionAndSizeBar'
...rfaceElvUI\Modules\actionbars\ActionBars.lua:326: in function `CreateBar'
ElvUI_ExtraActionBars\core.lua:53: in function `CreateBars'
ElvUI_ExtraActionBars\core.lua:85: in function `?'
...sic\Libs\CallbackHandler-1.0\CallbackHandler-1.0-7.lua:119: in function <...sic\Libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:119>
[C]: ?
...sic\Libs\CallbackHandler-1.0\CallbackHandler-1.0-7.lua:29: in function <...sic\Libs\CallbackHandler-1.0\CallbackHandler-1.0.lua:25>
...sic\Libs\CallbackHandler-1.0\CallbackHandler-1.0-7.lua:64: in function `Fire'
...ccountant_Classic\Libs\AceEvent-3.0\AceEvent-3.0-4.lua:120: in function <...ccountant_Classic\Libs\AceEvent-3.0\AceEvent-3.0.lua:119>

Code: Select all

1x ...rfaceElvUI\Modules\actionbars\ActionBars.lua:251: attempt to index field 'mover' (a nil value)
...rfaceElvUI\Modules\actionbars\ActionBars.lua:251: in function `PositionAndSizeBar'
ElvUI_OptionsUI\ActionBars.lua:751: in function <ElvUI_OptionsUI\ActionBars.lua:749>
[C]: ?
...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0-78.lua:51: in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:49>
...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0-78.lua:875: in function <...nfig-3.0\AceConfigDialog-3.0\AceConfigDialog-3.0.lua:696>
[C]: ?
...ddOns\AddOnSkins\Libs\Ace3\AceGUI-3.0\AceGUI-3.0-40.lua:72: in function <...ddOns\AddOnSkins\Libs\Ace3\AceGUI-3.0\AceGUI-3.0.lua:70>
...ddOns\AddOnSkins\Libs\Ace3\AceGUI-3.0\AceGUI-3.0-40.lua:290: in function `Fire'
...ic\Libs\AceGUI-3.0-40\widgets\AceGUIWidget-CheckBox.lua:68: in function <...ic\Libs\AceGUI-3.0\widgets\AceGUIWidget-CheckBox.lua:57>
My ElvUI.lua file is available here for reference: https://pastebin.com/tFqFdixp (look for the "Default" profile)

Any idea what's going on?

Image
Last edited by add1kted2ka0s on Fri Nov 08, 2019 5:31 pm, edited 1 time in total.

ElvUI ExtraActionBars

#4
add1kted2ka0s wrote:
Fri Nov 08, 2019 6:01 pm
:) Was working fine till like I updated ElvUI earlier today. Oh well.
Yes, that is because it is now integrated into ElvUI. So you don't need it anymore.
I always recommend backing up your WTF folder - where your profiles/settings for all addons, including ElvUI are stored.

Who is online

Users browsing this forum: No registered users and 1 guest