Page 1 of 1

error lua

Posted: Thu Nov 19, 2020 3:29 pm
by Limboubaoo
hi guys ,

i ve got this error since today
Message: ...ace\AddOns\ElvUI\Modules\Skins\Blizzard\WorldMap.lua:106: attempt to index field 'backdrop' (a nil value)
Time: Thu Nov 19 16:26:59 2020
Count: 1
Stack: ...ace\AddOns\ElvUI\Modules\Skins\Blizzard\WorldMap.lua:106: attempt to index field 'backdrop' (a nil value)
[string "=(tail call)"]: ?
[string "@Interface\AddOns\ElvUI\Modules\Skins\Blizzard\WorldMap.lua"]:106: in function <...ace\AddOns\ElvUI\Modules\Skins\Blizzard\WorldMap.lua:20>
[string "=[C]"]: ?
[string "@Interface\AddOns\ElvUI\Modules\Skins\Skins.lua"]:1404: in function <Interface\AddOns\ElvUI\Modules\Skins\Skins.lua:1399>
[string "=[C]"]: ?
[string "=[C]"]: ?
[string "@Interface\AddOns\ElvUI\Core\Core.lua"]:1662: in function `CallLoadFunc'
[string "@Interface\AddOns\ElvUI\Core\Core.lua"]:1677: in function `CallLoadedModule'
[string "@Interface\AddOns\ElvUI\Core\Core.lua"]:1703: in function `InitializeModules'
[string "@Interface\AddOns\ElvUI\Core\Core.lua"]:1785: in function <Interface\AddOns\ElvUI\Core\Core.lua:1753>
[string "=[C]"]: in function `Initialize'
[string "@Interface\AddOns\ElvUI\init.lua"]:156: in function <Interface\AddOns\ElvUI\init.lua:155>
[string "=[C]"]: ?
[string "@Interface\AddOns\ElvUI\Libraries\Ace3\AceAddon-3.0\AceAddon-3.0.lua"]:70: in function <...s\ElvUI\Libraries\Ace3\AceAddon-3.0\AceAddon-3.0.lua:65>
[string "@Interface\AddOns\ElvUI\Libraries\Ace3\AceAddon-3.0\AceAddon-3.0.lua"]:527: in function `EnableAddon'
[string "@Interface\AddOns\ElvUI\Libraries\Ace3\AceAddon-3.0\AceAddon-3.0.lua"]:630: in function <...s\ElvUI\Libraries\Ace3\AceAddon-3.0\AceAddon-3.0.lua:615>

Locals: <none>

error lua

Posted: Thu Nov 19, 2020 4:50 pm
by jewell616
I am getting the same error.

error lua

Posted: Thu Nov 19, 2020 9:35 pm
by Konecatdruid
Same here. It only occurs on log in but it's still annoying.

error lua

Posted: Fri Nov 20, 2020 1:46 pm
by Luckyone
Please type in chat /luaerror on and see if you can trigger the error again. This error is not caused by ElvUI.

error lua

Posted: Fri Nov 20, 2020 1:47 pm
by Luckyone
As annoying as it is - you guys need to troubleshoot before you post any error

error lua  [Accepted Answer]

Posted: Fri Nov 20, 2020 1:55 pm
by Konecatdruid
I've just logged in and the error is gone. I think it was either Tomcat's Tours or Handynotes that was causing it. If anyone here has the same addons listed below, try updating them and it may fix the issue like it did for me:

Auto Vendor Extended
AutoVendor
Caravana
CampionCommander
H.H.T.D
Handynotes (Pandaria, BfA, LegionTreasures. LostAndFound)
Tomcat's Tours (Rares and Death's Rising)
TomTom
Total RP 3 (Extended as well)
ElvUI
ElvUI OptionsUI
DBM

Hope this helps! :D

error lua

Posted: Fri Nov 20, 2020 1:57 pm
by Luckyone
Thanks for your tests!