Page 1 of 1

Strange interaction between ElvUI and Weakauras 2

Posted: Sun Jul 14, 2019 12:44 am
by s7wede
Version of ElvUI (use /estatus command ingame to check): 11.18

Disable all addons except the two called "ElvUI" and "ElvUI Config". Do you still experience the issue now?: No

Disable all addons and use the default UI to make sure it is not an issue with the WoW client itself. Do you still experience the issue?: No

Check for lua errors by using the command "/luaerror on" without quotes. Did you get an error or do you still experience the issue?: No

If you received an error then post it below (use the 'code' bbcode):
No lua error is produced

Please explain the issue you're having with as much detail as possible. Describe the exact steps we need to take in order to reproduce the issue.:
I am having a strange interaction between Weakauras 2 (2.13.4) and the latest version of ElvUI. When I randomly tab target or even select another mob while I am in combat, sometimes even out of combat, the nameplate already has debuffs on it. Some do not have timers running or sometimes they are not even debuffs I can produce. This happens to mobs that aren't even in combat.

Do you have any other information which might help us track down the issue?:
I have tested this with only Weakauras and Elvui running and can reproduce it at will.

We often get clues about the issue by looking at your entire UI, so please take some screenshots and add them here.:
Image
The mob is out of combat and has debuffs on it already
Image
even with addonskins loaded I am able to reproduce this with an out of combat mob
Image
what my UI looks like with me in combat with a mob and the debuffs I have applied.

Strange interaction between ElvUI and Weakauras 2

Posted: Mon Jul 15, 2019 9:04 pm
by s7wede
Just an update to this. I have discovered it's more an interaction between a style filter and ElvUI and has nothing to do with Weakauras 2. Specifically I get this interaction using a style filter that when an enemy NPC is not targeted and is not targeting the player, it shows Name Only. When I turn this specific style filter off this does not occur.
Image
Reproduced the error using /luaerror on.

Strange interaction between ElvUI and Weakauras 2

Posted: Tue Jul 16, 2019 1:14 am
by Simpy
hey, i just made some changes in our development branch to hopefully resolve this issue, if you wouldn't mind testing it out by installing the development version and replying that would be great. :) (also please remember to backup your WTF folder for addon settings / profile safety).

Instructions: viewtopic.php?f=20&t=33 (Please read: Installing ElvUI dev version).