Forum Rules:
Before creating a support thread here then please read [Read Before Posting] Ask For Technical Support: The Right Way.

When you create a new thread asking for support then please make sure you use the "ElvUI Tech Support" post template. See the link above for more information.

LUA Errors 11.22

Version of ElvUI (use /estatus command ingame to check): [11.22]

Disable all addons except the two called "ElvUI" and "ElvUI OptionsUI". Do you still experience the issue now?: [YES]

Disable all addons and use the default UI to make sure it is not an issue with the WoW client itself. Do you still experience the issue?: NO]

Check for lua errors by using the command "/luaerror on" without quotes. Did you get an error or do you still experience the issue?: [YES]

If you received an error then post it below (use the 'code' bbcode):



Please explain the issue you're having with as much detail as possible. Describe the exact steps we need to take in order to reproduce the issue.:
[So far as I can tell this error began with the last update 11.22. It seems to be triggered when I click and drag my bag to a different location and it also seems to happen whenever I am in a BG]

Do you have any other information which might help us track down the issue?:
[I can't say for sure but this error(s) also seemed to begin when I transferred my rogue from one server to another.]

We often get clues about the issue by looking at your entire UI, so please take some screenshots and add them here.:

LUA Errors 11.22

khanhor wrote:
Sat Sep 14, 2019 3:35 am
Erekel wrote:
Wed Sep 11, 2019 9:48 am
I went to the projects gitlab, and saw a fix for this issue in the develop branch and have temporarily applied it by hand, and the error is gone!

Would have been nice you had posted a link to the fix ... :)
yeah, i have this error too ((( only on RBG

LUA Errors 11.22


I tried that modified Battleground,lua you linked, but unfortunately the issue is still exist . Replaced the original 44-45. rows :
"self.text:SetFormattedText(displayString, dataStrings[pointIndex], E:ShortValue(select(pointIndex, GetBattlefieldScore(i))))"

to the new :
"local val = select(pointIndex, GetBattlefieldScore(i))
self.text:SetFormattedText(displayString, dataStrings[pointIndex], E:ShortValue(val))" but the message is still exists . :(
Already deleted all addons, and WTF dir as well. Reinstall Elv_UI, and still got the same problem.
Please help if any useful tips to solve this BG thing,

My current Battleground.lua :

local E, L, V, P, G = unpack(select(2, ...)); --Import: Engine, Locales, PrivateDB, ProfileDB, GlobalDB
local DT = E:GetModule('DataTexts')

--Lua functions
local _G = _G
local select = select
local strjoin = strjoin
--WoW API / Variables
local C_PvP_GetMatchPVPStatIDs = C_PvP.GetMatchPVPStatIDs
local C_PvP_GetMatchPVPStatColumn = C_PvP.GetMatchPVPStatColumn
local GetBattlefieldScore = GetBattlefieldScore
local GetNumBattlefieldScores = GetNumBattlefieldScores
local GetBattlefieldStatData = GetBattlefieldStatData

local displayString, lastPanel = ''
local dataLayout = {
['LeftChatDataPanel'] = {
['left'] = 10,
['middle'] = 5,
['right'] = 2,
['RightChatDataPanel'] = {
['left'] = 4,
['middle'] = 3,
['right'] = 11,

local dataStrings = {
[10] = _G.DAMAGE,
[5] = _G.HONOR,
[4] = _G.DEATHS,
[3] = _G.KILLS,

lastPanel = self
local pointIndex = dataLayout[self:GetParent():GetName()][self.pointIndex]
for i=1, GetNumBattlefieldScores() do
local name = GetBattlefieldScore(i)
if name == E.myname then
self.text:SetFormattedText(displayString, dataStrings[pointIndex], E:ShortValue(select(pointIndex, GetBattlefieldScore(i))))

function DT:BattlegroundStats()

local classColor = (_G.CUSTOM_CLASS_COLORS and _G.CUSTOM_CLASS_COLORS[E.myclass]) or _G.RAID_CLASS_COLORS[E.myclass]
local pvpStatIDs = C_PvP_GetMatchPVPStatIDs()
if pvpStatIDs then
for index = 1, GetNumBattlefieldScores() do
local name = GetBattlefieldScore(index)
if name and name == E.myname then
DT.tooltip:AddDoubleLine(L["Stats For:"], name, 1,1,1, classColor.r, classColor.g, classColor.b)
DT.tooltip:AddLine(" ")

-- Add extra statistics to watch based on what BG you are in.
for x = 1, #pvpStatIDs do
DT.tooltip:AddDoubleLine(C_PvP_GetMatchPVPStatColumn(pvpStatIDs[x]), GetBattlefieldStatData(index, x), 1,1,1)



function DT:HideBattlegroundTexts()
DT.ForceHideBGStats = true
E:Print(L["Battleground datatexts temporarily hidden, to show type /bgstats or right click the 'C' icon near the minimap."])

local function ValueColorUpdate(hex)
displayString = strjoin("", "%s: ", hex, "%s|r")

if lastPanel ~= nil then
E.valueColorUpdateFuncs[ValueColorUpdate] = true

LUA Errors 11.22

Benik wrote:
Fri Sep 20, 2019 11:56 am
No need to edit the files. Extract ElvUI and ElvUI_Options from this zip file: https://git.tukui.org/elvui/elvui/repos ... evelopment

Downloading this file, will always have the latest dev changes. Have in mind that since it's not a release version, you may experience side issues.
Replacing the ElvUI_OptionsUI folder in my WoW addons folder solved the error issue completely for me.

With WoW game off
1. ElvUI was at 11.22
2. Download development ElvUI development branch from link above
3. Extract zip
4. Delete the wowfolder\_retail_\Interface\AddOns\ElvUI_OptionsUI folder
5. Copy development branch ElvUI_OptionsUI folder from extracted folder from step 3 into wowfolder\_retail_\Interface\AddOns\
6. Start WoW normally

No more errors. Thanks, love this interface addon.

LUA Errors 11.22

When updating you should delete both ElvUI and ElvUI_OptionsUI and replace with the new folders.
I always recommend backing up your WTF folder - where your profiles/settings for all addons, including ElvUI are stored.

Who is online

Users browsing this forum: fBSN, Google [Bot] and 10 guests