Loading...

MoveAnything Issue

1
Yeah, yeah, yeah, I know. This isn't the MoveAnything site and you don't distribute it.

However, the current manager of MoveAnything has a project that is here (Z-Perl Unit Frames).

I opened a bug report in the first week of August about my issue with MoveAnything, but I'm not even sure he's still monitoring the Curse site (he seemed pretty bitter about something on a post I found in the Z-Perl Unit Frames page).

I can't figure out how to leave Resike (the Addon manager's name) a message here and I don't know if he's even logging into Curse any more.

My backpack frame, location and scale managed by MoveAnything, creeps around (well, up - not so much down or left or right). If left alone, it eventually creeps up far enough to overlap another frame I have in the area.

My UI is very tight and efficient. It's important to me to fix this.

I'm at a loss as to what could be causing it to move in the first place - it feels as if it might be some sort of cumulative rounding error - but the level of obfuscation in MoveAnything's code is more than I can decipher without a commitment larger than it would probably take for me to replace the functionality altogether.

There are also other bug reports on that page about drifting UI elements, so the addon needs a little attention.

I'm perfectly welcome to help in any way I can, but 1) I need to get some guidance as to where to go digging and 2) I'd like not to have to do this alone. If Resike is around or if any of you are in contact with him (or her, he could be a she), please give him my regards and nudge him towards this post.

P.S. Blazeflack - I'm keeping the code you gave me for the map, but I just can't live with the one-bag ElvUI bags and I can't get that other addon to work for me (plus, I *really* need the scaling to work for bags and that just hasn't been a nut I've been able to crack).
Ph'nglui mglw'nafh Cthulhu R'lyeh wgah'nagl fhtagn.

MoveAnything Issue

3
I'm hoping I have a solution.

I went back into MoveAnything's UI Configuration options, pulled up each of the bag frames, and pinned them, not to the UIParent frame, but to other bag frames.

In most cases, there is NO x or y offset (left to right, they set themselves in the right positions pretty well). With the backpack and the other bag (not bank bag) frames, I had to apply a -5 x offset to 3-5 and a -10 y offset to the backpack itself.

For the Backpack through BagFrame5 (my personal bags), I anchored the Backpack and BagFrame3 to BagFrame2 (the first "non-backpack" bag). BagFrame4 is anchored to BagFrame3. BagFrame5 is anchored to BagFrame4.

For the bank, BagFrame6 (extra bank bag 1) is anchored to the bank frame itself (top left to top right with a -3 y offset). Anchoring bags 7, 8 and 9 was done left anchored to right with zero offsets, 7 to 6, 8 to 7, 9 to 8 with 0/0 offsets. I anchored bag 10 to bag 6, top to bottom, zero offsets and then 11 to 10 and 12 to 11 left to right with zero offsets.

I'm hoping that altering the offsets to specific frames and forcing integer values into them might fix whatever Lua nuttiness is essentially randomizing (in a minor way) what is happening to my backpack y offset from UIParent.

Screenshot included for reference (yes, I'm very fussy about this - no, I can't change that about me - yes, I'm getting help for it and I'm taking my meds).
Image
P.S. I'm going to spend the day working on my WA setup. I'll likely be able to see if this has worked as it's during reloads that I noticed the "drift" of my backpack before. Good or bad, I'll post back this evening with results.

Thanks, Blaze.
Ph'nglui mglw'nafh Cthulhu R'lyeh wgah'nagl fhtagn.

MoveAnything Issue

4
Okay, I caught it failing.

This screenshot shows where I set the value for the offset for BagFrame1 (Backpack). It clearly shows that bag top-aligned with the array of buttons to its right.
Image

This screenshot shows the same BagFrame1 (Backpack) drifted lower. I opened the control window and confirmed that the offset value is still the same.
Image

I cannot figure out how this is happening or why. That offset is either being ignored or the location of the parent frame is being miscalculated or something else is wrong.

It's only ever wrong on the y-axis. It's only ever the backpack that drifts. It can creep up or down far enough to collide with or even overlay the frames above or below it.

Utterly maddening.
Ph'nglui mglw'nafh Cthulhu R'lyeh wgah'nagl fhtagn.

MoveAnything Issue

6
No, it's more to do with hearthing, any sort of portal use, visiting the bank, visiting the mailbox, or changing spec. I've had times where it changed, I went back to where I was before, logged out and back in and tried to repeat it and couldn't get it to happen.

It's maddeningly sporadic. It's only the backpack. It's only vertical movement. I'd say about 80% of the time it's UPWARD vertical movement (although this example, it's downward).

30 odd years in IT and this sort of problem is the nightmare - can't reliably cause it to repeat, no clue where the problem is.

I found that if I alter the offset, then alter it BACK, it reset to the proper location SOMETIMES (about 75% of the time). The rest of the time, it didn't.

I wish I had better information for you. I've been fighting this for months. It's indicative of something not working the way it should and may be a clue to a bigger problem, but I'll be darned if I know that that bigger problem is. I only use MA for my bags now. Even when I had a dozen things under its control, only the backpack was flakey.
Ph'nglui mglw'nafh Cthulhu R'lyeh wgah'nagl fhtagn.

MoveAnything Issue

7
I've been working at trying to make the problem repeatable and I think I have it.

Login. Open bags. Change spec. Bags shift.

In the current MoveAnything profile, I have BagFrame2 anchored to BagFrame1, BagFrame3 to BagFrame2, BagFrame4 to BagFrame3, and BagFrame5 to BagFrame4, so BagFrames 2-5 jump UP a little bit, but essentially, it's really the Backpack (BagFrame1) shifting down (it's fixed in place and since everything else is anchored to it, directly or indirectly, the other personal bags shift up - if I redefine the bags to be independently placed based solely on their coordinates relative to UIParent, only the Backpack moves).

If the bags are not open when you change spec, the corruption does not occur.

If the bags are closed when you change spec, the corruption is reversed.

If you logout, hearth, enter/exit an instance/raid/scenario regardless of bags open/closed, the corruption is reversed.

This is the text string for my MoveAnything configuration:

Code: Select all

frames:{[s:0.6599999666214,p:("LEFT","BankBagFrame1","RIGHT",0,0.00018310546875),n:"BankBagFrame2"],[p:("TOPLEFT","BankFrameItem1","BOTTOMLEFT",0,-163.99987792969),n:"BankBagSlotsMover"],[s:0.6599999666214,p:("TOPRIGHT","BankBagFrame1","BOTTOMRIGHT",0,-100),n:"BankBagFrame5"],[p:("BOTTOMLEFT","UIParent","BOTTOMLEFT",302.66690063477,736.49987792969),n:"BankFrame"],[s:0.6599999666214,p:("BOTTOM","BagFrame1","TOP",0,7.5757579588912),n:"BagFrame2"],[hi:1,p:("TOPLEFT","ContainerFrame1","TOPLEFT",4.545166015625,-46.272735595703),n:"BagItemSearchBox"],[s:0.6599999666214,p:("LEFT","BagFrame2","RIGHT",-7.5757579588912,0),n:"BagFrame3"],[p:("BOTTOM","QuickJoinToastButton","TOP",-4.166414643197,-108.16586258309),n:"ElephantButtonFrame"],[s:0.9647889317397,a:0.8,p:("TOPLEFT","UIParent","TOPLEFT",335.39306640625,-31.064293379235),n:"MAOptions"],[s:0.6599999666214,p:("TOPLEFT","BankFrame","TOPRIGHT",0,-47),n:"BankBagFrame1"],[s:0.6599999666214,p:("CENTER","UIParent","CENTER",958.8357324676,-557.99999256683),n:"BagFrame1"],[s:0.6599999666214,p:("LEFT","BagFrame4","RIGHT",-7.5757579588912,0),n:"BagFrame5"],[hi:1,p:("TOPRIGHT","ContainerFrame1","TOPRIGHT",-37.847900390625,-60.787963867188),n:"BagItemAutoSortButton"],[s:0.6599999666214,p:("LEFT","BankBagFrame3","RIGHT",0,0),n:"BankBagFrame4"],[s:0.6599999666214,p:("LEFT","BankBagFrame6","RIGHT",0,0),n:"BankBagFrame7"],[p:("BOTTOMRIGHT","BankSlotsFrame","BOTTOMRIGHT",-5,8.0000610351563),n:"BankFrameMoneyFrame"],[s:0.6599999666214,p:("LEFT","BankBagFrame5","RIGHT",0,0),n:"BankBagFrame6"],[p:("RIGHT","BankFrameMoneyFrameSilverButton","LEFT",-4.0000305175781,0),n:"BankFrameMoneyFrameGoldButton"],[s:0.6599999666214,p:("LEFT","BagFrame3","RIGHT",-7.5757579588912,0),n:"BagFrame4"],[s:0.6599999666214,p:("LEFT","BankBagFrame2","RIGHT",0,0),n:"BankBagFrame3"]},name:"Kaldara"
I've verified that the text string before the corruption occurs is identical to the text string after the corruption occurs.
Ph'nglui mglw'nafh Cthulhu R'lyeh wgah'nagl fhtagn.

MoveAnything Issue

8
This may be the most maddening AddOn I've ever used.

I thought cleaning things up might help, stripping out unused profiles and such.

I did that and then reloaded that one profile from the string that I had unloaded just a few hours earlier.

Chaos. Just chaos.

On load, my bags are scattered all over the screen. If I specifically open MoveAnything and click the selected profile again, they all line up just right.

But if I /reload or logout and back in, chaos again.

If I tried, I couldn't get something to be this flakey.

Is there another bag customization addon out there that will allow me to resize and move the bags as individual bags (NO GROUP BAG ADDON, PLEASE).
Ph'nglui mglw'nafh Cthulhu R'lyeh wgah'nagl fhtagn.

MoveAnything Issue

9
Turned off ALL of my addons except BugSack, BugGrabber, and AdvancedInterfaceOptions (for debugging).

Completely removed and reinstalled MoveAnything (including deleting both the MoveAnything.lua and MoveAnything.lua.bak files in SavedData).

Started over with my MoveAnything definitions (I just did the Bank Bags for now) as follows using the default profile:

BankBagFrame1 top left attached to BankFrame top right with 0, 0 offset.
BankBagFrame2 left attached to BankBagFrame1 right with 0, 0 offset.
BankBagFrame3 left attached to BankBagFrame2 right with 0, 0 offset.
BankBagFrame4 left attached to BankBagFrame3 right with 0, 0 offset.
BankBagFrame5 top attached to BankBagFrame1 bottom with 0, 0 offset.
BankBagFrame6 left attached to BankBagFrame5 right with 0, 0 offset.
BankBagFrame7 left attached to BankBagFrame6 right with 0, 0 offset.

Closed everything, exited the game completely, restarted the game, logged in on the character I'm testing this with. This is what I saw when I opened the bags (I did them one at a time so you can see where they all are, but when they're all open at once, they're still just as messed up):

Bank Bag 1
Image

Bank Bag 2
Image

Bank Bag 3
Image

Bank Bag 4
Image

Bank Bag 5
Image

Bank Bag 6
Image

Bank Bag 7
Image

I closed the bags and put the cursor over a button that does something MA calls "Synchronize"....
Image

There's no explanation of what "Synchronize" does, but in this case, it seems to impose the order I want. But why do I need to do that? Why do I need to open my bags, then TELL this thing that all that setup I wanted to do, I actually want it to do? Is all that setup somehow stored as a mild suggestion as to what I want rather than a directive? Is this addon just collecting data about what an orderly UI *might* look like?

After I click the Synchronize button, this is what the screen looks like (and should have looked like when I first opened the bank bags):
Image

This cannot POSSIBLY be how this is supposed to work.

Either MA needs to auto-synch or I'm doing something very, very wrong, but given that I'm doing ALL of it through the UI, and the UI isn't giving me any warnings, I have no idea WHAT.

Also, I noticed as I was setting things up that despite the fact that the anchor point on a bag I was moving was left or right or top left or top right, when it moved, it moved as if it were anchored to the frame's center. It was only after synchronization that it moved to the correct location.

I've tried this with named profiles. I've tried this with the default profiles. I've tried this with separate profiles for every character. I've tried this with separate profiles for every *class*. What the bleeding hell is going on with this thing?

If anyone has contact info for the current project manager (I think he manages Z-Perl Unit Frames as well, but I'm not absolutely sure), please get him in touch with me here. I'll do the digging and the grunt work if he needs me to, but I've got to have some direction. I cannot, simply cannot, decipher the baroque obfuscation of MoveAnything's code on my own.
Ph'nglui mglw'nafh Cthulhu R'lyeh wgah'nagl fhtagn.