Loading...
Forum Rules:
Before creating a thread here then please read [Read Before Posting] Ask For Technical Support: The Right Way.

When you create a new thread then please make sure you use the "ElvUI Tech Support" post template. See the link above for more information.

Elvui raid combat fps problem

#1
Version of ElvUI (use /estatus command ingame to check):
https://i.gyazo.com/c0f412727e6c5fff34d ... 15ee15.png
Disable all addons except the two called "ElvUI" and "ElvUI Config". Do you still experience the issue now?:
Yes, read below
Disable all addons and use the default UI to make sure it is not an issue with the WoW client itself. Do you still experience the issue?:
No issues without addons
Check for lua errors by using the command "/luaerror on" without quotes. Did you get an error or do you still experience the issue?:
No lua errors
If you received an error then post it below (use the 'code' bbcode):
No

Please explain the issue you're having with as much detail as possible. Describe the exact steps we need to take in order to reproduce the issue.:

I have fps drop only in raid combat (23-30 during BL in 20ppl, 30-40 in normal combat)(15-23 during bl in 30ppl) but for entire game content ( arenas, bg's, m+, open world with the highest setting no problem at all 60+ fps stable). Using all elvui modules excluded raid frames. Using only elvui and elvui_optionsUI

Do you have any other information which might help us track down the issue?:
Yes, i have tracked the most overloaded function by using elvui dev (screenshots after 20ppl raid combat). Also used addon cpu usage to illustrate that it doesn't cause by other addons (WA takes a lot but I tried without elvui it's around 10-12 fps improvement). Unfortunately, I was not able to use only elvui in raid combat.
https://i.gyazo.com/a857eb13b43712818c0 ... b8ae67.png
Note1: I don't use buff/debuff on nameplates on elvui so no any custom filtres.
Note2: using AMD Ryzen 2700x, 16gb ram, gtx980
Also, can you please explain what are overload functions for? Is it ok for them to take so much CPU usage? Maybe I can just turn something off and fix it.
I have only 1 clue it's corrupted profile ( used it for 3-4 years on many chars), but it will take too much time to rebuild and reproduce it xD maybe there are no connections at all.
If you need more information or some clarification ask me, please.
Thanks for your attention anyway.
We often get clues about the issue by looking at your entire UI, so please take some screenshots and add them here.:
https://i.gyazo.com/625e80cf90b8c7e3f21 ... 65e8cc.jpg

Elvui raid combat fps problem

#2
You can go into raid finder with only ElvUI to test. Disabling ElvUI doesn’t point to the issue being ElvUI.

There are other addons that use ElvUI resources, or don’t load unless ElvUI is enabled.

You need to test with ONLY ElvUI enabled. To quickly disable all other addons type in chat in game
/luaerror on
I always recommend backing up your WTF folder - where your profiles/settings for all addons, including ElvUI are stored.

Elvui raid combat fps problem

#3
Botanica wrote:
Tue Aug 13, 2019 10:39 pm
You can go into raid finder with only ElvUI to test. Disabling ElvUI doesn’t point to the issue being ElvUI.

There are other addons that use ElvUI resources, or don’t load unless ElvUI is enabled.

You need to test with ONLY ElvUI enabled. To quickly disable all other addons type in chat in game
/luaerror on
So i did as you said, have something like that https://gyazo.com/62a882ac38f035c7c3cd21512f08c5e7 https://gyazo.com/9adc8a239ec11d74a082c842c64f6fe9 seems like Unitframes:checkFilter load my elvui a lot.
In screenshots, it's 50 fps but it's only elvui enable in semi-afk LFR raid, with some other addons loadded and full active raid fps problem felt more a lot. With no elvui I have around 80fps in LFR
This thing starts to load elvui only when boss combat begins, in trash pack, I didn't even see that (Trash pack for example: sorry for bad quality did it from unprepared recording) https://i.gyazo.com/ffad7923ed0f9b87793 ... e01d02.jpg

Who is online

Users browsing this forum: No registered users and 6 guests