ProjectAzilroka "Movable Frames" conflicts with Leatrix Map

Version of ElvUI (use /estatus command ingame to check): 1.13 for Classic

Version of ProjectAzilroka: 1.54 for Classic

Version of Leatrix Map: 1.13.33 for Classic

Disable all addons except the two called "ElvUI" and "ElvUI OptionsUI". Do you still experience the issue now?: No, it works fine.

Disable all addons and use the default UI to make sure it is not an issue with the WoW client itself. Do you still experience the issue?: No, it works fine

Check for lua errors by using the command "/luaerror on" without quotes. Did you get an error or do you still experience the issue?: No error reported

If you received an error then post it below (use the 'code' bbcode):
No error reported

Please explain the issue you're having with as much detail as possible. Describe the exact steps we need to take in order to reproduce the issue.:
When the "Movable Frames" component of ProjectAzilroka is enabled, I cannot move the world map provided by Leatrix Map anymore.
Disabling "Movable Frames" restores the expected functionality of being able to move the map.

Do you have any other information which might help us track down the issue?:
Enabling "Movable Frames" but disabling the handling of the World Map frame in ProjectAzilroka's options does not resolve this issue.

We often get clues about the issue by looking at your entire UI, so please take some screenshots and add them here.:

ProjectAzilroka "Movable Frames" conflicts with Leatrix Map

Azilroka wrote: Wed Oct 09, 2019 4:16 pm It was working for me when I did it.. Maybe Leatrix changed something too.
I just tried reverting to Leatrix Map 1.13.33 but no luck for me :(

I tried enabling/disabling Leatrix Map options "Unlock map frame" and "Remove map border" in any possible combination to no avail.
Checking "Use default map" generates a ton of lua errors when trying to open the map, and it doesn't open anyway.

I also tried enabling/disabling ElvUI's handling of the map (option "Maps > Map > Enable") but it still changes nothing.

Again, unchecking "WorldMapFrame" in ProjectAzilroka "Movable Frames" module doesn't help either.

The weird thing is, I get no errors at all, it just doesn't work...
Well it kinda works now, meaning I can move the map about 2 millimeters left/right but that's all.

[EDIT] I also tried completely deleting both Leatrix Map and ProjectAzilroka (addons and WTF folders) before reinstalling them, but it doesn't help either.

ProjectAzilroka "Movable Frames" conflicts with Leatrix Map

I could not get Leatrix Map to work with your addon no matter what I tried so, here's what I did:

I installed Mapster + Handy Notes, which both work flawlessly with ProjectAzilroka, then I copied Leatrix Map's "Zoom map" code (the only "missing" functionality) in Mapster.lua and now I have a working setup.

It's clearly not the cleanest method but it serves my purpose anyway.

Thanks for your help though ! ;)